手機版 官方微博
官方微信
掃描關注:理想財富微信公眾號
RSS
  • 搜帖子

請老師將薛斯通道主圖出現笑臉時選股(已解決!感謝鄭云老師)

[通達信]
設置
5416 23 免費使用7799 Lv.4 發表于 · 2012-2-5 09:23 舉報 只看樓主 復制 倒序瀏覽 |
跳轉到指定樓層
請老師講薛斯通道指標出現笑臉的時候編寫個預警


AA:=MA((2*CLOSE+HIGH+LOW)/4,5);
通道1:=AA*102/100;
通道2:=AA*(200-102)/100;
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
通道3:=(1+7/100)*DD;
通道4:=(1-7/100)*DD;
股價:=(H+L+C)/3;
股價運動:=股價,LINETHICK2,COLORBLUE;
趨勢:=XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(股價,3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),3),LINETHICK1,COLORFFFFFF;
風險區1:趨勢*1.1,COLOR0000FF;
風險區2:趨勢*1.125,COLOR0000FF;
風險區3:趨勢*1.15,COLOR00FFFF,POINTDOT;
良機區1:趨勢*0.9,COLORLIBLUE;
良機區2:趨勢*0.875,COLORLIBLUE;
良機區3:趨勢*0.85,COLORFFFF00,POINTDOT;
上一:IF(風險區1>REF(風險區1,1), 風險區1,DRAWNULL),COLORYELLOW;
上二:IF(風險區2>REF(風險區2,1), 風險區2,DRAWNULL),COLORYELLOW;
上三:IF(風險區3>REF(風險區3,1), 風險區3,DRAWNULL),COLORYELLOW;
下一:IF(良機區1>REF(良機區1,1), 良機區1,DRAWNULL),COLORYELLOW;
下二:IF(良機區2>REF(良機區2,1), 良機區2,DRAWNULL),COLORYELLOW;
下三:IF(良機區3>REF(良機區3,1), 良機區3,DRAWNULL),COLORYELLOW;
DRAWBAND(上三,RGB(0,0,255),上二,DRAWNULL);
DRAWBAND(上二,RGB(255,255,0),上一,DRAWNULL);
DRAWBAND(下一,RGB(80,00,00),下二,DRAWNULL);
DRAWBAND(下二,RGB(255,255,255),下三,DRAWNULL);
DRAWBAND(上一,RGB(128,128,64), 下一,DRAWNULL);
{IF(趨勢>REF(趨勢,1), 趨勢,DRAWNULL),COLORYELLOW,LINETHICK2}
T:=CLOSE/REF(CLOSE,1)*1000-1000;
QS2:=XMA(XMA(XMA(T,2),2),2);
QS4:=XMA(XMA(XMA(T,4),4),4);
QS6:=XMA(XMA(XMA(T,6),6),6);
{DRAWICON(CROSS(QS2,QS4),L,1);
DRAWICON(QS2<QS4 AND REF(QS2,1)>REF(QS4,1),H,2);}
風險:=((C-趨勢)/趨勢*100>10  AND C>通道3) OR ((H-趨勢)/趨勢*100>10  AND H>通道3 ) OR ((O-趨勢)/趨勢*100>10  AND O>通道3);
DRAWICON(風險 AND FILTER(風險,3),H+0.01,6);
良機:=((C-趨勢)/趨勢*100<-10 AND C<通道4) OR ((O-趨勢)/趨勢*100<-10  AND O<通道4 ) OR((L-趨勢)/趨勢*100<-10  AND L<通道4);
QW1:=趨勢>REF(趨勢,1);
DRAWICON(良機 AND QW1 AND FILTER(良機,3),L*0.97,5);
QW2:=O<良機區3;
DRAWICON(QW2 AND FILTER(QW2,3),L*0.97,9);
E1:EXPMA(C,7),COLORGREEN;
E2:EXPMA(C,9),COLORGREEN;
E3:EXPMA(C,12),COLORGREEN;
E4:EXPMA(C,14),COLORGREEN;
E5:EXPMA(C,17),COLORGREEN;
E6:=EXPMA(C,50),COLORFF8800,LINETHICK2;
就:IF(E1>REF(E1,1),E1,DRAWNULL), COLOR0080FF;
這:IF(E2>REF(E2,1),E2,DRAWNULL), COLOR0080FF;
樣:IF(E3>REF(E3,1),E3,DRAWNULL), COLOR0080FF;
做:IF(E4>REF(E4,1),E4,DRAWNULL), COLOR0080FF;
多:IF(E5>REF(E5,1),E5,DRAWNULL), COLOR0080FF;
DRAWKLINE(H,O,L,C);
STICKLINE(C>=O,H,L,0,1),COLOR0000FF;
STICKLINE(C>=O,C,O,2.8,0),COLOR0000BB;
STICKLINE(C>=O,C,O,2,0),COLOR0000DD;
STICKLINE(C>=O,C,O,1.2,0),COLOR0000EE;
STICKLINE(C>=O,C,O,0.4,0),COLOR0000FF;
STICKLINE(C<O,H,L,0,1),COLORFFFF00;
STICKLINE(C<O,C,O,2.8,0),COLOR999900;
STICKLINE(C<O,C,O,2,0),COLORBBBB00;
STICKLINE(C<O,C,O,1.2,0),COLORDDDD00;
STICKLINE(C<O,C,O,0.4,0),COLORFFFF00;
STICKLINE(C<O,H,L,0,0),COLORFFFF00;
A1:=(E1>REF(E1,1) AND E2>REF(E2,1) AND E3>REF(E3,1) AND E4>REF(E4,1) AND E5>REF(E5,1)) AND (REF(E1,1)<=REF(E1,2) OR REF(E2,1)<=REF(E2,2) OR REF(E3,1)<=REF(E3,2) OR REF(E4,1)<=REF(E4,2) OR REF(E5,1)<=REF(E5,2));
A2:=風險區1>REF(風險區1,1) AND 風險區2>REF(風險區2,1) AND 風險區3>REF(風險區3,1) AND 良機區1>REF(良機區1,1) AND 良機區2>REF(良機區2,1) AND 良機區3>REF(良機區3,1);
DRAWICON(A1 AND A2,L*0.99,25);

[ 本帖最后由 免費使用7799 于 2012-2-5 10:08 編輯 ]

附件

1.jpg

2.55 KB, 下載次數: 4

1.jpg
鄭云2009
Lv.7
發表于 2012-2-5 09:42 復制 2樓 只看該作者
原帖由 免費使用7799 于 2012-2-5 09:23 發表
請老師講薛斯通道指標出現笑臉的時候編寫個預警


AA:=MA((2*CLOSE+HIGH+LOW)/4,5);
通道1:=AA*102/100;
通道2:=AA*(200-102)/100;
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CL ...

附件

解答內容.txt [預覽]

1009 Bytes, 下載次數: 19, 下載積分: 共享幣 -5 個

周建華1968
Lv.4
發表于 2012-2-5 11:31 復制 4樓 只看該作者
本帖隱藏的內容需要回復才可以瀏覽
老鼠PK貓咪
Lv.4
發表于 2012-2-5 13:55 復制 6樓 只看該作者
感謝風行!!!!!!!!!!!!!!
周陳
Lv.3
發表于 2012-2-27 19:21 復制 9樓 只看該作者
78888888888888
比干2011
Lv.6
發表于 2012-2-27 22:54 復制 11樓 只看該作者
謝謝鄭老師的辛勤勞動
革命者2020
Lv.3
發表于 2012-3-1 20:52 復制 12樓 只看該作者
向老師學習!!!!!!!!!!!!!!!!!!!!!!!!!!
清風綽影
Lv.3
發表于 2012-10-13 13:53 復制 15樓 只看該作者
指標不錯!!。。。。。。。。。。。。。。。
小民1978
Lv.4
發表于 2012-10-16 13:01 復制 16樓 只看該作者
謝謝鄭云老師,指標也不錯
飛白
Lv.3
發表于 2012-10-24 22:59 復制 17樓 只看該作者
喜歡薛斯通道。。。。
婉蝶秋子
Lv.2
發表于 2012-10-25 08:58 復制 18樓 只看該作者
看看看看看看啊看那
精鷹1
Lv.1
發表于 2014-10-13 22:41 復制 19樓 只看該作者
感謝風行!!!!!!!!!!!!!!
星星間的風
Lv.3
發表于 2015-1-11 18:49 復制 21樓 只看該作者
源碼一測試就退出通達信了。
山里的娃娃
Lv.0
發表于 2019-10-5 21:31 復制 22樓 只看該作者
源碼一測試就退出通達信了
您需要登錄后才可以回帖 登錄 | 免費注冊

本版積分規則

回頂部 到頁底
快速回復 返回頂部 返回列表
满地美女二3肖6码牛特