手機版 官方微博
官方微信
掃描關注:理想財富微信公眾號
RSS
  • 搜帖子

求老師給改一個DMI選股公式以通過大智慧(已解決:鄭云2009)

[大智慧]
設置
5010 24 虎威錢龍 Lv.4 發表于 · 2011-6-21 08:11 舉報 只看樓主 復制 倒序瀏覽 |
跳轉到指定樓層
源碼為:


n:=14;
mm:=6;
MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD:=HIGH-REF(HIGH,1);
LD:=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI:=DMP*100/MTR;
MDI:=DMM*100/MTR;
ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,MM);
ADXR:=EXPMEMA(ADX,MM);
a1:=pdi<mdi and pdi<adx and pdi<adxr;
a2:=last(a1,n,1);(從N天前到昨天持續存在PDI在三線下方運行,n自定)
a3:=(c-ref(c,1))/ref(c,1)>0.05;
a4:=dynainfo(17)>1.5;(量比大于1.5,可根據需要改)
a2 and a3 and a4n

不勝感激!!!

[ 本帖最后由 虎威錢龍 于 2011-6-21 08:20 編輯 ]
鄭云2009
Lv.7
發表于 2011-6-21 08:16 復制 2樓 只看該作者
游客,如果您要查看本帖隱藏內容請回復
聆聽財富
Lv.3
發表于 2011-6-21 12:24 復制 3樓 只看該作者
謝謝志志老師!!!
大牛牛2010
Lv.5
發表于 2011-6-22 22:42 復制 5樓 只看該作者
謝謝志志老師!!!
紅星閃閃789
Lv.4
發表于 2011-6-23 18:27 復制 6樓 只看該作者
謝謝志志老師!!!
天地人007
Lv.2
發表于 2011-10-26 21:03 復制 14樓 只看該作者
謝謝志志老師!!!
沉默cge
Lv.6
發表于 2011-11-7 23:52 復制 15樓 只看該作者
謝謝志志老師!!!
小散戶100
Lv.3
發表于 2012-5-7 16:00 復制 17樓 只看該作者
謝謝志志老師!!!
西門一飄
Lv.5
發表于 2014-10-1 00:00 復制 18樓 只看該作者
謝謝志志老師!!!
熊貓王
Lv.4
發表于 2016-3-25 22:15 復制 19樓 只看該作者
學習    學習     謝謝
熊貓王
Lv.4
發表于 2016-3-25 22:16 復制 20樓 只看該作者
學習  學習  謝謝.................
劍噬天下
Lv.2
發表于 2016-3-26 18:49 復制 21樓 只看該作者
謝謝! 謝謝! 謝謝!
小蝦161
Lv.2
發表于 2019-10-6 00:36 復制 22樓 只看該作者
N:2,90,7;
M:2,60,7;


TR :=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI:=DMP*100/TR;
MDI:=DMM*100/TR;
ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
ADXR:=EXPMEMA(ADX,M);
買點:(CROSS(PDI, MDI)AND CROSS(PDI, ADX)AND CROSS(PDI, ADXR))AND CLOSE>OPEN
AND C/REF(C,1)>0.5 AND VOL>MA(VOL,5)*1.5,COLORRED,LINETHICK3;

請問老師 這個為什么通達信不能通過?
快樂簡單人
Lv.6
發表于 2019-10-6 12:52 復制 23樓 只看該作者
謝謝    學習了
您需要登錄后才可以回帖 登錄 | 免費注冊

本版積分規則

回頂部 到頁底
快速回復 返回頂部 返回列表
满地美女二3肖6码牛特